WordPressのcocoonテーマでエラーが出る

WordPressのcocoonテーマで、下記のエラーが表示される。

/wp-content/themes/cocoon-master/lib/open-graph.php(356)

調べると、curlを使った処理でエラーになっていた。PHPのモジュールでcurlが入っているかみたところ、インストールされていなかった。FreeBSDのパッケージからcurlのモジュールをインストールして、apacheを再起動した。これで、解決した。

 pkg install php73-curl

WordPressで、xml_parser_create()のエラーが発生した

PHPをPHP5.6からPHP7.3に上げたところ、Wordpressで以下のエラーが発生した。

Fatal error: Uncaught Error: Call to undefined function xml_parser_create()

PHPのオプションで、xmlに関するモジュールがインストールされていないことが原因だった。FreeBSDでパッケージからインストールしているので、下記のようにpkgコマンドでインストール。その後、Apacheを再起動し、無事にエラーは解消。

pkg install php73-xml-7.3.8